
WIDA Student Import (Pre-ID File) for 2024-2025 | Layout and Instructions

Instructions:
Information on the Student Import (Pre-ID) file is used to load students into WIDA AMS. Some SEAs also use the Pre-ID file upload to
place the initial order of ACCESS for ELLs testing materials for the state. Refer to your state's ACCESS for ELLs checklist for
information about how your state handles initial materials ordering.

To submit your Student Import (Pre-ID) file, you will need to create or edit it as a CSV file. CSV, which stands for
“comma-separated values,” is a simple file format used to store tabular data, such as a spreadsheet or database. Files in the CSV
format can be imported to and exported from databases like the one used by DRC.

Usually, you’ll create or edit CSV data in Microsoft Excel. Use Excel to open the CSV file. To
save if CSV is not the default format:

● Excel 2016 or later: File > Export > Change File Type. Under Other File Types, choose CSV (Comma delimited).
● Older versions of Excel: File > Save As > Save as type. From the drop-down menu, choose CSV (Comma delimited).

To handle overall formatting and retain leading zeros when a file is opened in Excel, import the file into a blank Excel document
by selecting Data > From Text/CSV > Import > Transform Data > Unselect the Changed Type in Applied Steps
> Close & Load > Import Data. (This is for Windows only; this is not Mac compatible.) See above instructions for saving as
.CSV once you have finished with the file. Instructions for .CSV formatting may differ between device type and OS version.

Below are some general file and field rules to follow when creating your CSV. Refer to the “Acceptance Values”, “Examples”, and
“Required?” columns in the layout below to help you create your Student Import (Pre-ID) file.
See the “Changes/Notes for 2024-2025” column for changes and previous column locations.

File Rules:
❖ File must contain a header row.
❖ File must contain the data in the order listed in the file layout.
❖ File must be in a comma separated (.csv) format.
❖ Each student must appear ONLY ONCE in the data set.

Field Rules:
The field rules outlined in these instructions are for the initial student data upload.
❖ Fields cannot be longer than the value in the “Max # of Characters” column; fields indicated by an asterisk will be

truncated if the submitted data is longer than the specified length.
❖ Fields cannot contain commas.
❖ All fields are not case sensitive.
❖ For fields that are not required, Blank is a valid value.
❖ Mode of Administration (AI) is required when the Pre-ID file will be used for ordering student test materials for ACCESS.
❖ When Mode of Administration (AI) is equal to P (i.e. Paper), you must also complete Paper Tier (AJ).
❖ If you are ordering materials via Material Ordering in WIDA AMS, both Mode of Administration (AI) and Paper Tier (AJ) are not

required.
❖ Refer to the Field Lengths for District and School Numbers table at the end of this document to identify how long your

District Number and School Number fields should be.

Entering Accommodations:
All accommodations for a student are entered in a single field, separated by a pipe (|).
❖ Refer to the list of available accommodations contained within the example field in the layout below.
❖ Use the Shift + Backslash keys to create the pipe symbol. (|)
❖ Pipes are accepted but not required for a student with no accommodations.
❖ Pipes are accepted but not required for single accommodations or after the last accommodation in the entry.
❖ Do not use spaces between pipes.
❖ If Braille accommodations are listed for a student, then do not list LP (Large Print) for the same student.
❖ If Braille accommodations are listed for a student, then Mode of Administration (AI) and WIDA Alternate ACCESS Tester

(AK) must be blank for the same student.

For subsequent imports, rules based on your state’s profile and your WIDA AMS user role may impact the fields that can be
updated. If you need a subsequent student import, and have questions about what data you can override, please contact DRC
Customer Service at 1-855-787-9615 (TTY: 763-268-2889.



Column
Letter

Column
Header

Max
Length

Acceptance Values Examples Required? Changes/Notes for
2024-2025

A Testing Program 1 A = ACCESS
S = Screener

The value cannot be left blank and it must match
the Registration Window selected in Import
Management.

A Y New required column to
differentiate the import file for
ACCESS or Screener.

B State Name
Abbreviation

2 2 Letter State Code.

Valid values: A-Z.

AL Y Reordered column.

C District Name 50 For Reference only. District Name N Reordered column.
D District Number 15 Unique District Number identifying district within

the state.

District Number must already exist in AMS.
This is an identifier and not necessarily a numeric
field.

Valid values:
A-Z,
0-9,
Cannot be blank.

AL001 Y Reordered column.

E School Name 50 For Reference only. School Name N Reordered column.

F School Number 15 Unique School Number identifying school within
the district.

School Number must already exist in AMS.
This is an identifier and not necessarily a numeric
field.

Valid values:
A-Z,
0-9,

0001 Y Removed “When Site Type =
"District" this field is Blank.” –
not applicable.

Reordered column.

G State Student ID 15 Unique Student ID value within a state.
This must be unique and not blank.

Valid values:
0-9,
A-Z.

Length does not need to be consistent within the
state, but if the ID includes leading zeros, they
must be included.

0000067890 Y Reordered column.

H District Student ID 15 Unique Student ID value within a district.

This is considered a "pass-through" field and
whatever is received will be accepted.

123456789 N Reordered column.

I Student Last Name 100* Valid values:
A-Z,
hyphen/dash
“-“, spaces,
apostrophe " ' " ,
period “.”.

Not accepted: commas, accents, tildes,
nor any other special characters.

* Name would be truncated in reporting.

Brown Y Reordered column.

J Student First Name 100* Valid values:
A-Z,
hyphen/dash
“-“, spaces,
apostrophe " ' " ,
period “.”.

Not accepted: commas, accents, tildes,
nor any other special characters.

* Name would be truncated in reporting.

Charlie Y Reordered column.
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Column
Letter

Column
Header

Max
Length

Acceptance Values Examples Required? Changes/Notes for
2024-2025

K Student Middle
Name

100* Valid values:
A-Z,
hyphen/dash “-“,
spaces,
apostrophe " ' "
, period “.”, or
Blank.

Not accepted: commas, accents, tildes,
nor any other special characters.

* Name would be truncated in reporting.

A N Reordered column.

L Birth Date 10 MM/DD/YYYY,
or Blank.

01/01/2005 N Reordered column.

M Gender 1 M = Male,
F =Female,
or Blank.

Other values will be accepted, but will appear blank
on reports

M N Reordered column.

N Grade 2 Kindergarten through 12th grade.

00 = Kindergarten,
01 through 12,
Must contain leading zero for 01-09.

05 Y Reordered column.

O Primary Disability 3 AS = Autism Spectrum Disorder, DB
= Deaf-blindness,
DD = Developmental Delay,
HI = Hearing Impairment, including Deafness,
ID = Intellectual Disability,
MD = Multiple Disability,
OI = Orthopedic Impairment, OHI
= Other Health Impairment, ED =
Emotional Disturbance,
SLD = Specific Learning Disability,
SLI = Speech or Language Impairment,
TBI = Traumatic Brain Injury,
VI = Visual Impairment, including Blindness, or
Blank.

AS N Reordered column.

P Secondary Disability 3 AS = Autism Spectrum Disorder, DB
= Deaf-blindness,
DD = Developmental Delay,
HI = Hearing Impairment, including Deafness,
ID = Intellectual Disability,
MD = Multiple Disability,
OI = Orthopedic Impairment, OHI
= Other Health Impairment, ED =
Emotional Disturbance,
SLD = Specific Learning Disability,
SLI = Speech or Language Impairment,
TBI = Traumatic Brain Injury,
VI = Visual Impairment, including Blindness, or
Blank.

TBI N Reordered column.

Q Student Type 1 Student is
N = Non-Public (Private), C
= Charter,
H = Homeschool, P = Public, or Blank (which
defaults to Public).

C N Reordered column.

R LIEP Classification 3 EBL = EL Bilingual, MBL
= Mixed Bilingual,
ETI = EL-Specific Transition Instruction, MNL
= Mixed Class with Native Language
Support,
EEO = EL-Specific with English-only Support, MEO
= Mixed Class with English-only Support, NSP = No
Support Provided, or Blank.

MBL N Reordered column.
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Column
Letter

Column
Header

Max
Length

Acceptance Values Examples Required? Changes/Notes for
2024-2025

S LIEP - Parental
Refusal

1 Y = Yes,
or Blank.
Indicates if the student's parent has refused
language services.

Y N Reordered column.

T LIEP - Optional Data 9 Space for up to 3, 3-letter codes for more specific
program identifiers, or Blank.

CATTWI N Reordered column.

U Length of Time in
LEP/ELL Program

2 Length of Time in LEP/ELL Program in a
US school (regardless of country of origin).

Valid values are 00-19.

Represented in whole number of years by school
year. Number of years that a student has been in a
bilingual or ESOL program. Round down: year and
10 months=01 (A kindergarten student is always
00.) Don't include Pre-K ESOL services. Use best
estimate.

If not possible to get the information, leave blank.

00 N Reordered column.

V Ethnicity -
Hispanic/Latino

1 Y = Yes, or Blank Y N Reordered column.

W Race - American
Indian/Alaskan
Native

1 Y = Yes, or Blank. Y N Reordered column.

X Race – Asian 1 Y = Yes, or Blank. Y N Reordered column.
Y Race - Black/African

American
1 Y = Yes, or Blank. Y N Reordered column.

Z Race - Pacific
Islander/Hawaiian

1 Y = Yes, or Blank. Y N Reordered column.

AA Race – White 1 Y = Yes, or Blank. Y N Reordered column.

AB Native Language 4 Unique code identifying language for each state.
This is a state defined field.

This is considered a "pass-through" field and
whatever is received will be accepted.

112 N Reordered column.

AC Date First Enrolled
US School

10 Date student first enrolled in a US school
(regardless of country of origin).

MM/DD/YYYY (Must include slashes), or Blank.

08/30/2011 N Reordered column.

AD Title III Status 1 Y = Yes,
or Blank.

Y N Reordered column.

AE Migrant 1 Y = Yes,
or Blank.

Y N Reordered column.

AF IEP Status 1 Y = Yes, or Blank. Y N Reordered column.
AG 504 Plan 1 Y = Yes, or Blank. Y N Reordered column.

4



Column
Letter

Column
Header

Max
Length

Acceptance Values Examples Required? Changes/Notes for
2024-2025

AH Accommodation 100 MC = Manual control of item audio,
RA = Repeat item audio,
ES = Extended speaking test response time,
SD = Interpreter signs test directions in ASL,
IR = In-Person Human Reader,
RP = Repeat In-Person Human Reader,
 SR = Scribe,
WD = Word processor or similar keyboarding
device to respond to test items,
RD = Student responds using a recording device,
NS = Test may be administered in a non-school
setting,
EM = Extended testing of a test domain over
multiple days.

Accommodations for ACCESS Paper Only:
LP = Large Print

Braille Accommodations
NC = UEB Contracted ACCESS Grades 01-05,
UEB with Nemeth Grades 06-12,
NU = UEB Uncontracted ACCESS Grades 01-05,
UEB with Nemeth Grades 06-12,
TC = UEB Math/Science Contracted (Formerly
Technical),
TU = UEB Math/Science Uncontracted
(Formerly Technical), or Blank.

Only one Braille Accommodation or Large Print may
be chosen. If selected, Mode of Administration (AI)
and WIDA Alternate ACCESS (AK) must be blank.

Example =
MC|RA|ES

Multiple
accommodations
can be entered
for a student.

Each
accommodation
must separated
by a Pipe (|)
delimiter.

Pipe delimiter is
created by using
the shift
backslash key. •
Pipe is accepted
but not required
for blanks, single
accommodations,
or after the last
accommodation.

No spaces
between pipes (|)

N Added clarifying text for paper
accommodations only.

WIDA Alternate ACCESS
name change.

Reordered column.

AI Mode of
Administration

1 WIDA Screener Online
O = Online generic registrations are
created
Blank = default to O and online
registrations are created 

WIDA ACCESS
Valid Values when using this file to import
students into WIDA AMS (if allowed by
state policy): Blank.

Valid values when using the Pre-ID file for
ordering student test material:
P = Paper (Grades 01-12),
O = Online (Grades 01-12), or
Blank = Paper when Grade = 00, WIDA Alternate
ACCESS Tester = Y, or Accommodations include
LP or Braille.  Otherwise, student is assumed to
be an Online ACCESS tester.

“P” = Used to calculate paper test materials.
Student will NOT be placed in online generic
registrations.

“O” = Used to calculate online test materials.
Student will be placed in online generic
registrations. DRC will send Online ACCESS
handwriting materials for Grades 01-03 and
appropriate handwriting materials for Grades
04-05 based on state profile.

If a student is marked or defaulted to Online then
the student will be placed in online generic
registrations. DRC will not send paper handwriting
booklets unless paper materials are ordered
through WIDA AMS Materials Ordering.

O Y/N Separated out Screener and
ACCESS mode of
administration valid values. 

Updated where blank is valid
for LP Kindergarten and to
use correct terminology
should be registrations and
not test sessions 

WIDA Alternate ACCESS
name change. 

Reordered column.
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Column
Letter

Column
Header

Max
Length

Acceptance Values Examples Required? Changes/Notes for
2024-2025

AJ Paper Tier 2 Applicable for Paper ACCESS only.

Valid values when Mode of Administration
(AH) = P:

A,
BC.

Valid values when Mode of Administration
(AH) = O or Blank:

Blank.

BC Y/N Added clarifying text to

indicate that this field is only

applicable for paper ACCESS.

Reordered column.

AK WIDA Alternate
ACCESS Tester

1 Y = Yes, for Grades 00-12 testing WIDA Alternate
ACCESS or Blank =ACCESS for ELLs Online,
Paper, Kindergarten, Braille.

If "Y" then Mode of Administration (AH) must be
blank and student cannot have Braille

(NC,NU,TC,TU) or Large Print (LP)
Accommodations.

Used to determine if WIDA Alternate ACCESS
Materials should be sent for the student.

Y N WIDA Alternate ACCESS name

change.

Reordered column.

AL State Defined
Optional Data

10 State Designated Additional Data - Defined by
State.

This is considered a "pass-through" field and
whatever is received will be accepted.

See State
Provided Special
Instructions

N Reordered column.

AM District Defined
Optional Data

10 District Designated Additional Data - Defined by
District.

This is considered a "pass-through" field and
whatever is received will be accepted.

See State
Provided Special
Instructions

N Reordered column.

AN Additional field to be
used by a state if
needed

50 State Additional Data.

This is considered a "pass-through" field and
whatever is received will be accepted.

See State
Provided Special
Instructions

N Reordered column.
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Field Lengths for District and School Numbers for 2024-2025
Use this table to identify the length for the District Number and School Number fields.

WIDA Consortium
Member

District

Length

School
Length

Example for District
Number

Example for School
Number

Alabama 5 4 AL015 0055

Alaska 4 6 AK14 147010

Bureau of Indian Education 11 6 BIBOS123456 987654

Colorado 6 4 CO0120 1556

Delaware 6 4 DE0037 0730

DoDEA 6 6 DDEUSO 444444

Florida 4 4 FL01 0112

Georgia 9 4 GA0000613 2050

Hawaii 5 3 HI919 104

Idaho 5 4 ID381 0168

Illinois 13 4 IL05016036002 2001

Indiana 6 4 IN6895 7217

Kansas 7 4 KSA1234 1234

Kentucky 5 3 KY595 310

Maine 6 4 ME1016 1174

Maryland 4 4 MD12 0265

Massachusetts 10 8 MA02390000 02390515

Michigan 7 5 MI82155 06130

Minnesota 11 3 MN000101000 094

Missouri 8 4 MO096102 1050

Montana 6 4 MT0716 0817

Nevada 5 6 NV016 016201

New Hampshire 6 5 NH0441 21375

New Jersey 6 3 NJ4420 050

New Mexico 5 3 NM087 026

North Carolina 8 3 NC00043C 43C

North Dakota 7 4 ND49009 3633

Northern Mariana Islands 5 3 MP001 023

Oklahoma 8 3 OK59I001 705

Palau 5 3 PW101 101

Pennsylvania 12 5 PA0127041503 00642

Rhode Island 4 5 RI39 39118

South Carolina 6 3 SC3901 028

South Dakota 7 2 SD49007 01

Utah 4 3 UT10 104

Vermont 8 5 VT0SU052 PS137

Virgin Islands 5 3 VI001 125

Virginia 5 4 VA127 0370

Washington 7 4 WA14005 2834

Washington DC 6 4 DC0001 0206

Wisconsin 6 4 WI6692 0140

Wyoming 10 8 WY00502000 00202001
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